Laser Cutter Recommended Software

The following software may be useful for creation or troubleshooting of laser cutting designs:

Inkscape

inkscape.org
Inkscape is a free and open source vector graphics editor but can also be used to export DXF files suitable for laser cutting from your design.

For best compatibility with LaserCut 5.3 a few settings should be changed in Inkspace's preferences: Geometric Bounding Box should be selected under Tools (Edit → Inkscape Preferences → Tools), and Grid units should be set to mm under Grids (Edit → Inkscape Preferences → Interface → Grids → Rectangular grid). You should also ensure that your document is using mm for it's default units, this can be set during file creation or changed in the Document Properties (File → Document Properties → Page).

AutoDesk Fusion360

autodesk.com
Fusion360 is a full featured industry standard 2D/3D CAD package. Not ideal for beginners, however it is some of the best software for advanced CAD design work.

While Fusion360 is expensive paid software Autodesk provide a free licence for hobbyists and makers that many Hackspace users will qualify for - see here for details. Autodesk have a range of video tutorials available, however they do assume some existing CAD knowledge.

LibreCAD

librecad.org
LibreCAD is a free and open source CAD application and a fork of the popular, now closed source, QCAD.

While LibreCAD is a full 2D CAD package in its own right, one of its most useful features is its ability to save modern DXF files in older formats. Open a DXF file and then File → Save As, choose DXF R14 for best results with LaserCut 5.3.

OpenSCAD

openscad.org Although this open source application is primarily used for 3D work, 2D work is also supported by 2D primatives and projection() from 3D objects. OpenSCAD is a programming language rather then a GUI and is great for parametric and computed designs. The DXF output is compatible with LaserCut 5.3.

One useful tip for work which has an outline to be cut and areas to be engraved : use the pattern difference() { outlines; engraved;} to get both sets of paths into the DXF.

LaserCut Demo

Installation Files
While you will still need to use the laser PC for actual use, LaserCut 5.3 can be installed on your own computer (Windows only). The installer is /Just Add Sharks Software/Laser Cutter Software/SetUp.exe within the linked ZIP file.

The main program will not work without a licence, however Lasercut53_Demo.exe in the installation directory will work and import DXF files. File → Save is disabled in this demo however if you exit the program the save dialogue has not been removed, therefore this can be used to check your DXF files and configure your cutting parameters at home. See LaserCut 5.3 File Preparation.

Lightburn

Lightburn is a popular, more functional laser controller application, but sadly only the proprietory LaserCut software will work with the MPC6515 controller in our laser cutter.

  • equipment/a0_laser_cutter/software
  • Last modified: 7 weeks ago
  • by kit.wallace