LaserCut 5.3 File Preparation

Introduction

LaserCut 5.3 is a piece of proprietary software to interface with Leetro MPC based laser cutters such as ours. While it has some limited design functions it is most useful for importing DXF files generated by “proper” CAD software and sending them to the laser cutter.

Units

LaserCut does not handle unit mismatch gracefully and operates only in mm. You should ensure all units are set to mm in your design to avoid sizing issues.

Colours

LaserCut uses specific colours as “layers” to signify different paths. By using these specific colours in your designs layer information can be preserved when moving from your design software to LaserCut, but the colours must match an option present in LaserCut to be recognised.

While 39 colours are available in LaserCut, the following 7 are considered DXF safe and should be retained on export from most CAD software.

Colour Hex Code R Value G Value B Value
Black #000000 0 0 0
Red #FF0000 255 0 0
Green #00FF00 0 255 0
Blue #0000FF 0 0 255
Cyan #00FFFF 0 255 255
Magenta #FF00FF 255 0 255
Yellow #FFFF00 255 255 0

Note: To avoid confusion Red should be avoided as this is used to signify a selected area in LaserCut.

DXF Versions

There are multiple versions of the DXF file spec. LaserCut has been observed to have best compatibility with DXF R14, and this should be used if it is an option in your program of choice. If this is not possible check your file carefully after importing, or use LibreCAD in the Laser Cutter Recommended Software to change the version.

File Handling

Files created outside of LaserCut need to be imported rather than opened, using the Import button or File → Import. Recommended file formats are AutoCAD DXF (.dxf) for cutting or vector engraving and Bitmap (.bmp), Jpeg (.jpg/.jpeg) or TIFF (.tif/.tiff) for raster engraving.

When saving a project in LaserCut 3 files will be produced:

  • An ECP (.ecp) file containing the design
  • An INI (.ini) file containing cut settings
  • A G00 (.G00) file containing engraving information

When opening an ECP file LaserCut looks for the INI and G00 files in the same directory automatically. If the files are missing (or if an ECP file is imported as above, rather than opened) the design and colour information will be retained but layer order and laser settings will be lost. For ease of managing these sets of files it is recommended to manually save each project into it's own folder.

The LaserCut Interface

The LaserCut interface consists of file handling, navigation and advanced function buttons long the top row, design tools on the left, the laser options panel on the right and a colour palette on the bottom row. Tooltips will show the name of a tool if the mouse is hovered over a button. The box in the centre refers to the 1200x900mm work area of the laser cutter. Please note if you are planning on using the honeycomb bed the actual usable area is slightly smaller due to the frame.

Most tools in LaserCut will act only on parts of your design that are selected. Individual vector lines can be selected with the Pick tool, and the whole design can be selected by using the Pick tool, or pressing CTRL+A. Selected parts are shown in red regardless of their colour, making red lines impossible to distinguish from selected lines.

Design Tools

Sizing and Placing Designs

When importing a design it may initially be incorrectly sized, and may be placed outside of the work area. To solve this select your entire design and click the Size button on the left toolbar or choose Tools → Size. In the pop up enter the desired size in in mm in one axis and click the “…” button for the other axis to keep the aspect ratio the same. Resizing can also be done by dragging a corner of the selection, however this is not useful for accurate sizing.

Once the design is the correct size, with your design still selected, click the Centre to table button on the left toolbar to centre your design, or drag the blue X in the centre of the design to manually move it into the work area.

Immediate Mode

If the Immediate checkbox in the laser settings panel on the right is unchecked then the design will be cut where it is placed within the work area shown on screen. There are no reference markings on the laser bed itself however, and this mode requires re-downloading your design to the laser cutter each time in order to move it around your material.

If The Immediate checkbox is check checked then the placement within the work area no longer matters, as long as the design is not outside the work area. In this mode the origin point can be moved and set using the controls on the laser cutter and corresponds to the knife origin point in LaserCut, shown by a blue dot on the edge of the design. This can be moved by pressing the Set knife origin button or Laser → Set laser origin and choosing one of the radio button options.

Here both the Immediate checkbox on the right of the interface and the knife origin (blue dot) in the upper left of the design can be seen.

Tiling

To cut multiple identical objects it is possible to tile your design by pressing the Copys button on the left toolbar and specify a number of times to tile and gap between each copy per axis. No gap can will result in the very edges being cut twice, unnecessarily increasing scorching along these cuts. For more advanced tiling options such as the ability to automatically tile to fit a material size, click the Set array output options button in the top toolbar. Nesting or intelligent tessellation are not possible within LaserCut.

Unite Lines

When a file is imported it will often contain many separate cuts to make up one shape. The start/stop point for a cut is shown as a yellow node on the line. To optimise each shape into one continuous cut, so that the cut is faster and has less scorching due to overlap, go to Tools → Unite lines. In the Unite lines options window choose a tolerance to use when calculating lines to merge. A large value will combine shapes that should remain separate. See the before and after below.

Layers

LaserCut uses colours to signify layers. These allow you to choose the order of cuts or to cut parts of the design using different settings. Unless you have incorporated LaserCut compatible colours into your design all lines will be black by default. To change colours select the area to change and click on a colour from the bottom palette. In the image above the design uses two layers, Blue and Black. In the laser settings panel to the right these are ordered so that Blue will be cut first, so that the inner detail will be cut before the piece is cut out from the sheet material. To change the order click on one of the layers in the laser settings panel, and click the Up or Down buttons.

Laser Settings

For each layer in the laser settings panel there is a drop-down menu under the mode column with the following options: Cut, Engrave, GradeEngrave and Hole.

Cut (Vector)

This tool is somewhat poorly named since this is also the same method to perform a vector engraving, by using the same principals as cutting but with a power low enough to not fully penetrate the material.

In this mode the laser will follow the vector lines in your design at the speed and power specified the number of times set in the “#” column. Multiple passes should only be used if needed as they typically reduce the quality of cuts and due to Carbon build-up have a dramatic reduction in effectiveness after the first pass. To set the number of passes type directly into the “#” column.

To set the speed and power double click on either of these columns. The Set cut options window will open.

  • Blow radio buttons: Turns on and off the air assist. If there isn't a good reason the air assist should always be used. On our laser cutter this option is inverted, therefore Not Blow means Blow!
  • Speed: The speed in mm/s to make the cut. This will depend on your material choice. Pay extra attention if using low speeds (<~15mm/s) due to the increased fire risk.
  • Power: Percentage power to the laser tube. This will also depend on your material choice. The laser is unlikely to fire below ~25-30%, and must never be used above 75%. Doing so will dramatically decrease the lifespan of the tube for little to no gain in cutting power!
  • Corner Power: Unless you are using a very slow speed the laser will have to slow down when making curved cuts. A general rule is 5-10% less than the Power setting works in most cases.
  • Overlap: A not well documented setting intended to compensate for laser calibration. Leave at 0.
Engrave (Raster)

Primarily used to engrave raster (pixel based) images rather than vector line drawings. In this mode the laser head will move back and forth over the material in a similar manner to an inkjet printer, taking significantly longer than a vector operation. Inputs should either be a high contrast black and white Bitmap, Jpeg or TIFF image where black will be engraved and white will not, or or an enclosed vector shape where the entire inner area will be engraved. Double click on the Power or Speed columns to open the options.

  • Speed: The speed in mm/s for the laser head to use when moving. This will depend on your material and desired depth of engrave.
  • Power: Percentage power to the laser tube. This will also depend on your material choice and desired depth of engrave. The laser is unlikely to fire below ~25-30%, and must never be used above 75%. Doing so will dramatically decrease the lifespan of the tube for little to no gain in cutting power!
  • scan gap: The distance in mm between each pass. This will depend on your desired look, but 0.085 equates to 300DPI and will produce a full coverage engraving with no obvious lines.
  • ExpandScale: Over or Under-scan options. Usually not needed.
  • Bi-dir: Turns engraving on the return pass on or off. This should usually be on for faster engraving.
  • Blow: Turns on and off the air assist. If there isn't a good reason the air assist should always be used. On our laser cutter this option is inverted, therefore Unchecked means Blow!
GradeEngrave (Raster)

The save as Engrave but will “bevel” the edges of engraved areas. Potentially useful for making stamps.

  • Grade-width: Size of bevel transition in mm
Hole (Vector)

A vector based mode similar to cut, but will perforate holes along the line rather than a solid cut. The holes are just tine dots made with a static laser, so the only limited control over hole size is the Radiation time setting. Double click on the Speed or Power column to open the options.

  • Power: Percentage power to the laser tube. This will depend on your material choice. The laser is unlikely to fire below ~25-30%, and must never be used above 75%. Doing so will dramatically decrease the lifespan of the tube for little to no gain in cutting power!
  • Hole on centre: If checked the laser will make one hole in the geometric centre of each shape, instead of perforating along the centre.
  • Interval: Distance in mm between holes.
  • Blow: Turns on and off the air assist. If there isn't a good reason the air assist should always be used. On our laser cutter this option is inverted, therefore Unchecked means Blow!
  • Radiation time: Time in seconds to hold the laser on each hole. A small increase may produce a slightly larger hole but longer wait times are unlikely to have any effect other than melting/scorching/fire!

Downloading to the Laser Cutter

Once your design is ready to be cut you must download it to the laser cutter. With the laser powered on press the download button at the bottom of the laser options panel, the Stand-alone file manage window should open. Click Del all to delete the previous file followed by Download current to download the current design. If you get an error message or file manager with many unnamed files in it, the laser cutter may be off or the USB connection may have been interrupted requiring unplugging and reconnecting. The the laser cutter is the silver USB cable in the front of the laser PC.


Continue using the controls on the laser cutter itself, please see the Laser Cutter Operation guide.

  • equipment/a0_laser_cutter/prep
  • Last modified: 6 days ago
  • by felix.h